by Joakim

External links in Visual Studio 2012 not working when running as administrator (Windows 8)

UPDATED 2: I did manage to find a solution for this problem, which is explained in this post.

UPDATED: I have found that this problem only occurs if you have set some other browser than IE to be the default program for the HTTP and HTTPS protocols (Chrome in my case, haven’t tested with Firefox, Opera, etc.). So, if IE is your default browser in Windows 8, or you’re running Visual Studio 2012 without elevated privileges, you won’t experience this problem.

If you have configured your web application project to use IIS, you have to run Visual Studio as administrator in order for Visual Studio to be able to access the IIS metabase (you won’t be able to load the project otherwise). The same is true if you just want to attach the Visual Studio debugger to website running in IIS without having configured the project to use IIS specifically (this way you will be able to load the project in Visual Studio without administrator privileges though).

I often do set up my web application project to use IIS, or at least I run the website in IIS and attach the debugger to the IIS process, and thus I usually run Visual Studio with administrator privileges. However while doing this, I have discovered a quirk (bug) in Visual Studio 2012 (I don’t think i was this way in 2010, but since I no longer have VS2010 installed I can’t verify it right now). When you run Visual Studio 2012 as  administrator, clicking on external links like the “More Information”-link on a Visual Studio extension, or the “Project Information”-link on a NuGet package doesn’t do anything (you don’t even get a warning or error message).

VS2012_ExternalLinks_1

VS2012_ExternalLinks_2

Clicking on the links depicted above should open your default browser and allow you to read about the extension/package.

The workaround is of course to run Visual Studio as a normal user, but it is quite annoying, especially with regards to NuGet package info if you have set up your web application project to use IIS.

This also affects extension updates, if the update button is supposed to download an external package (i.e. the update doesn’t happen inside Visual Studio).

I couldn’t find any info about this problem having been reported to Microsoft, so I also reported it as a bug.

  • http://blog.degree.no/bloggere/ Njål

    Clicking the links works fine here when running as Administrator: http://screencast.com/t/DoOeLN0Q9. But I am running VS2012 Ultimate – there might be a problem with the other versions.

  • http://www.degree.no Joakim

    @Njål Well, then I guess there isn’t a logical explanation, but rather a bug. My guess is that it is related to running it under Windows 8 (should have mentioned in the post that I’m running Win 8 RTM). You’re still running Windows 7, right?

  • Andre Vianna

    I am running VS2012 Ultimate under Windows 8 and I have exactly the same problem. I’ve tested the other scenarios and you are right It only happens if you run as admin with a default browser other than IE.

  • Pingback: External links in Visual Studio not working – Solution | Degree Blogg()

  • Pingback: Error when clicking a hyperlink in Outlook (Win8/Chrome) | Degree Blogg()